【分享】jfinal+jetty+jsp之No JSP support问题

jetty环境下如何支持jsp,波总在文档里写的很清楚了,我今天说的是一个很诡异的事情。

文档里jetty-jsp版本使用的是9.2.26.v20180806,但是这两年我用的是9.3.0.M1,也一直没有问题。但是这几天出幺蛾子了,系统能正常启动,但是访问页面的时候就报错。

No JSP support.  Check that JSP jars are in lib/jsp and that the JSP option has been specified to start.jar

找了好几天原因也没找到,今天我把版本降下来换成文档里那个版本。咦?就那么神奇,正常了!

具体原因我还没有找到,但是把jetty-jsp版本降下来后就解决了,有条件的小伙伴可以试一下。

评论区

山东小木

2022-01-14 12:32

咋还用jsp这个老古董?

happyboy

2022-01-14 13:05

@山东小木 老项目,懒得升级了。

杜福忠

2022-01-14 15:02

@happyboy 我们也有老项目,,,以前的项目一个功能就是一个页面,,,也没有抽取,,,真是懒得改了,费时间,还有稳定性问题。。。新项目用新架构,没毛病哈哈 ,老项目还是用Tomcat靠谱些。。。

zzutligang

2022-01-15 16:42

@杜福忠 项目能运行,就不要动,这是"行规"